WEBclient - проблемы с GET запросом

WEBclient - проблемы с GET запросом

Пользовательские блоки для коммкникации и связи GSM, GPRS, IR, Bluetooth и другие
Правила форума
Рекомендации по размещению блоков:
Автор блока создает подробное описание блока, отличие от подобных(если есть на данный момент).Сложные блоки очень желательно с примерами.
При выходе новых версий редактирует/дополняет свой первый пост с указанием даты, версии, причины.
В каждой теме обсуждается только выложенный автором блок - баги, возможность (или предложение) доработки и прочие хотелки.
Свои блоки, переработанные, с другими библиотеками, протоколами и т.д.- размещаем либо сами отдельно, либо обсуждаем и дорабатываем в форуме Разработка блоков.
Пользователи улучшив блок автора и проверив его работоспособность - могут обратиться к автору или модераторам с просьбой добавить их версию блока в первое сообщение темы.
Ответить
Pretorianecx
Рядовой
Сообщения: 5
Зарегистрирован: 06.06.2020{, 21:46}
Репутация: 0
Имя: Евгений

WEBclient - проблемы с GET запросом

#1

Сообщение Pretorianecx » 02.05.2021{, 23:53}

Добрый день.
Я часто практиковал процесс работы с WEBclient и GET запросами.
Возникла проблема, перестал приходить ответ.
Ставишь галку на пункт в меню Только тело, но в ответ приходит пустота, нечего.
После когда галку убираешь, выходит статус подключения и нужный мне ответ методом GET.
Вопрос, почему перестал приходить ответ от метода GET ? Менял версии программ, менял ардуино.
HTTP/1.1 200 OK
Date: Sun, 02 May 2021 20:57:47 GMT
Server: Apache/2.4.46 (Ubuntu)
Upgrade: h2,h2c
Connection: Upgrade, close
Content-Length: 13
Content-Type: text/html; charset= utf-8

Hello, World!
Такой ответ приходит когда снимешь галочку с пункта Только тело.
А когда ставишь эту галочку Только тело, то пустота, а должен выйти Hello, World!
Заранее спасибо!

Ответить

Вернуться в «Коммуникация и связь»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость